Zend Framework – Adding Doctrine ORM into Zend Framework 1.8+

I will add more details as to add things to your application.ini file, but for now

I want to record some OS specific notes – namely for those using Mac OSX.

I kept getting the error:
‘Couldn’t locate driver named mysql’

I ran into this problem when I was trying to create models from the command line (terminal).

My php.ini in MAMP was including the pdo_mysql.so – so I didn’t understand what in the world was going on. After a bit of searching I got the idea that it was using the base PHP included with the OS instead of my installed MAMP installation – sure enough that was it.

So in the terminal I needed to make sure I was running the MAMP version of php by pre-fixing my command with:
/Applications/MAMP/bin/php5/bin/php

Instead of: php

Then everything was happiness and glory.

More to come… I’m just starting with this.

Thursday, August 27th, 2009 Doctrine, Zend Framework

Leave a Reply

You must be logged in to post a comment.

[ad code=1 align=center]